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4Use the Tessellate tool to split the top surface of the

phone into four as shown. Select the control points

that make up the new horizontal section with the Bull’s-

eye tool and move them up to about two thirds of the

way up the original surface, using the Stretch tool.

5Using the Extrude tool pull out an aerial shape from

the bottom left section of the surface as shown. Do

this freehand (without holding down the spacebar to

constrain the extrude) so you can give the aerial a

tapered end. Change the object’s name to “case”. Model

names will be carried through into Director.

6Set the surface at bottom of the screen recess as the

working plane and then delete that surface. Switch

to a non-perspective top view and add a grid primitive

that’s slightly larger than the screen recess. Name it

“screen”, switch to a side view and move it into the recess.

10 Reset the model’s orientation. Select Render >

Materials Editor (C-L). Change the buttons

group’s diffuse colour to a charcoal grey and the screen’s

diffuse colour to dull grey/green.The case’s colour will be

set in the Director movie.Validate the changes.

11 Pick the phone group and then move and rotate

it so it is upright and placed at the origin (the

centre of the workbench).This is the default position and

orientation the phone model will have in the Shockwave

3D file we create. Also, it will rotate around the world ori-

gin in our movie.

12 Select File > Save (C-S) to back up the phone

model to your hard disk and then finally select

File > Export > OBJ. Save the phone model as

“phone.obj” and OK the dialogue box that appears with-

out ticking its check box. Quit Amapi 3D.

WORKING WITH 3D IN DIRECTOR 8.5 
Our mobile phone product demonstration will lead

you through the basics of creating and using Shockwave 3D

content in Director 8.5.

HOW TO

THE NEW SHOCKWAVE 3D component of the Director 8.5
Shockwave Studio shows huge potential for creating games, inter-

active environments and product demonstrations, but there’s no doubt

that working with 3D graphics is a complex process. In this 

tutorial we will lead you through the creation of a simple product

demonstration where the user can freely rotate a 3D model of a mobile

phone and see how it looks with different colour schemes applied.This

will explain the basic principles of using Shockwave 3D cast members.

Director’s Shockwave 3D content is stored in the proprietary W3D file

format. At the time of writing no Mac 3D modelling packages support

this format, so we’ll build our phone model in Amapi 3D 6, export it in OBJ

format and then utilise Macromedia’s freeware 3DSpeedport Xtra (grab it

at: download.macromedia.com/pub/director/obj/mac/
obj_converter.sit) to convert it into a W3D file.

This tutorial assumes a basic knowledge of Amapi 3D and Director. All

the media files used in the tutorial, including the mobile phone model

in Amapi, OBJ and W3D formats, are included on the Cover CD.

➔

The finished animation will show the phone in different colours.

ON THE CD
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ADD COMMENTS
Always comprehensively comment the Lingo scripts you write.
Although they may appear straightforward when you initially
write them, when you return to them a few months later you are
likely to have forgotten how they function. Thorough comment-
ing is particularly important when developing projects as part of
a team, or where the scripts will be maintained by someone other
than the original author.

FIND CAST MEMBERS
On large projects it can be easy to lose track of where cast mem-
bers are used in the Score. A fast way to locate them is to select
them in the Cast window and then pick Edit > Find > Selection
(C-H). The search will be conducted from the currently selected
frame in the Score, or from the beginning if none is selected. Use
Edit > Find Again (C-O-F) to jump to the next occurrence.

SEEING DOUBLE
If you can afford to buy an extra display and graphics card and
run your Mac as a dual monitor set-up, then do. Director has many
floating palettes and so screen space is at a premium. More
importantly, having two displays enables you to preview your
movie exactly as it will be seen by the end user on one, while
keeping the Score, Cast and Director’s other palettes and windows
available on the other.

TIPS
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STEP ONE: Modelling the mobile phone in Amapi

1Launch Amapi. Create a small cube primitive in the

centre of the workbench and then extrude the left or

right face so it has two sections. Now mould the mesh as

shown using the Stretch tool. Remember that when

using many tools the spacebar cycles through con-

strained motion along each axis.

2Now we will round off the edges of the basic phone

shape with the Chamfer tool. In Select Edges mode

pick the outside edges highlighted in the above screen-

shot.You will need to press the + key several times to

increase the radius of the chamfers.

3Extrude the top front face in and then down as

shown to form the recess that will hold the screen.

Next move the top side of the recess with the Stretch

tool so it is roughly halfway down the surface.Then apply

a slight chamfer to the outside edges of the recess.

7Set the keypad surface that we will be adding but-

tons to as the working plane. Create a cube primitive

above the case and resize it to form a thin rectangular

button shape.Then chamfer the top edges as shown and

name the object “button”.

8Use the Lay On tool to rest the button on the keypad

surface. Copy and paste the button twice and move

the duplicates to form a row.Then S-select the buttons

in the row to group them and repeatedly copy, paste and

move the group to form five columns.

9Open the hierarchical viewer, select one of the but-

ton groups, press C-U and ungroup all the buttons.

Now press C-G and group all the button objects as “but-

tons”.Then group the case, screen and buttons group and

call the new group “phone”.

1First install the 3DSpeedport Xtra in Director’s Xtra

folder. Launch Director and select Xtras > Convert 3D

Files... to open the conversion dialogue box. Clicking on

the Browse button enables you to set where the result-

ing W3D files will be saved.

2Click the Add button, navigate to the phone.obj file

and open it. Click the Convert button to save a W3D

version of the phone model. Note that the separate but-

ton models we had in Amapi will be fused into one in the

W3D file as they all have the same name.

3Now select File > Import (C-R). Navigate to the

phone.w3d file on your hard disk, add it to the file

import list and click the Import button.You can view the

new cast member in the Shockwave 3D window by dou-

ble-clicking on its icon in the Cast.

STEP TWO: Using the 3DSpeedport

➔
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BUTTONS 2
Another way to set up irregular-shaped buttons is to include the
button graphics as part of a single bitmapped background image,
and then place vector shapes with 0% blend over the top. It’s
these vector shapes that have the button behaviours or scripts
attached. You could provide feedback to the user by varying the
vector button’s transparency from Lingo.

CROSS-PLATFORM  MOVIES
If you are making a cross-platform movie you should be aware
that a given size of text looks roughly 33% larger on a Windows
PC than it does on the Mac. That is because the Mac assumes a
screen resolution of 72dpi, whereas Windows PC uses 96dpi. One
way to work around this is to rasterise text in a graphics package
and import it into Director as a bitmapped cast member.

BUTTONS 1
If you have an irregularly shaped button that is represented by a
bitmapped cast member you can set the button sprite’s ink mode
to Matte so only mouse clicks that are actually within the button’s
graphic, rather than in the sprite’s bounding box, are registered.
This shouldn’t slow down your movie’s playback as the button is
not being animated.

TIPS

1We painted this simple background, including button

graphics, in Photoshop using the oval selection, fill and

rotation tools. It was saved as a Photoshop file called

“background.psd”. A 300 x 300 pixel section from x 315, y

45 was also saved separately as “backdrop.psd”.

2In Director click on the Movie tab in the Property

Inspector and set its dimensions to 640 x 480 pixels.

Then select File > Import. Navigate to the

background.psd and backdrop.psd images on your 

hard disk, add them to the import listing and click the

Import button.

3Drag the background to the first frame of channel 1

in the Score. In the Property Inspector set its size to

640 x 480 and centre it on the Stage.Then drag the

phone cast member to the first frame of channel 2.

Resize it so it’s 300 x 300 pixels and move it to x 465 y

195 on the Stage.

1Pick Insert > Media Element > Text.Type

“GlobalMobiles” into the text editor that opens.

Highlight the text and set it to centred, 36-point

Helvetica. Drag out the text field’s end marker so the text

fits on a single line with a little room to spare. Close the

text editor window.

2Drag and drop the text from the Cast onto the top left

corner of the Stage as shown. Click on the Text tab in

the Property Inspector. Choose 3D Mode from the Display

pop-up menu.The text will now be displayed in 3D on

the Stage.Tick the Direct to Stage check box.

3to 5 and set the Background colour to the same

bright red (rgb 100%, 0%, 0%) that’s used in the

background image, the Ambient light to mid tone grey

(rgb 50%, 50%, 50%) and the Diffuse colour to bright

orange (rgb 100%, 60%, 0%).

1Select Window > Script (C-0) to open the scripting

window. Click on the plus button.We will use an on

startMovie event handler in this movie script to set up

the Shockwave 3D phone. If this was going to be a

Shockwave movie you would need to set the phone cast

member to preload.

2This line of Lingo sets the diffuseColour property of

the case model to bright blue (rgb 0, 0, 255). Note

that this command, like the other Lingo we will be using,

affects the contents of the phone cast member, not just

this particular 3D sprite instance of it.

3If you play the movie now you’ll notice that the

screen and button models don’t rotate with the case.

These two addChild commands resolve this by assigning

the screen and button models as children of the case.The

#preserveWorld parameter ensures they retain their posi-

tion when added.

STEP THREE: Setting up the movie

STEP FOUR: Creating 3D text

STEP SIX: Controlling 3D cast members through Lingo
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CREATING GRAPHS
A good way to create graphs in Director is to use a vector shape
line which has control points placed along it where you want to
have values displayed. You can then use the moveVertex Lingo
function to morph the line to form the graph. This is also a great
way to display live streaming information, such as a Shockwave
movie that tracks the fluctuating values of shares.

SPOTLIGHTS
Here’s a way of producing cool spotlight effects using sprite inks.
First set the Stage’s background colour to black. Then place the
element you want to function as the spotlight (it can be a bitmap
or vector shape) in channel 1 of the Score, assign it the Matte ink
and give it a white foreground and black background. Finally put
the bitmap you want to be illuminated in channel 2 and set its
ink to Darkest.

2D AND 3D SPRITES
By default 3D sprites are drawn direct to stage. This helps to keep
animation smooth but also prevents 2D sprites from being drawn
on top of them. One way around this is to use the addOverlay
Lingo command to include bitmapped cast members within the
scene itself. The overlay retains its position relative to the camera
view, no matter what the camera’s orientation. You can also use
the addBackdrop command to include a static background.

TIPS PHOTOSHOP MASTERCLASS DIRECTOR 8.5 MASTERCLASS 

4Using the Rectangle tool draw a square enclosing the

red button. Name the shape cast member “button”. In

the Score, copy the button, paste in two copies and then

position them over the other button graphics on the

Stage. S-select all the button sprites and give 

them No Line.

5Now we’ll add some descriptive text.With the Text

tool click on the Stage and type the description

shown. Select Modify > Font... (C-S-T) to style it.We

have used Helvetica; 12-point with 15 spacing for the

body copy, 24-point with 24 spacing for the title.

6Select Window > Library Palette. Choose Navigation

from the Library Palette’s pop-up menu to view the

navigation behaviours. Drag and drop the Hold on

Current Frame behaviour from the library into the script

channel of frame 28 in the Score.

1Pick 3D > Actions from the Library Palette’s pop-up

menu. Drag and drop the Automatic Model Rotation

behaviour onto the “GlobalMobiles” text on the Stage.

Set the speed to 1 and the rotation axis to X. OK the 

dialogue box.This independent action will continually

rotate the text.

2Drag and drop the Drag Model to Rotate behaviour

onto the phone sprite on the Stage. Change the

Which model? pop-up menu to Case and click the OK

button. As this is a local action a trigger must be attached

to the phone sprite to activate it.

3Select 3D > Trigger from the Library Palette’s pop-up

menu. Drag and drop the Left Mouse behaviour onto

the phone sprite. Accept the default values by clicking

the OK button.This will let you freely rotate the case

model on the X and Y axis.

4To make the phone look like it’s floating on the

movie’s background we will add a static backdrop to

the 3D sprite.The newTexture command creates a tex-

ture based on the “backdrop” cast member, the

addBackdrop command assigns that texture as a back-

drop for the sprite. Close the Script window.

5Select the red button in the Cast and then pick

Modify > Sprite > Script... (C S ‘).This attaches a

new behaviour script containing a mouseUp event han-

dler.The Lingo we have typed in here changes the diffuse

colour of the Shockwave 3D phone sprite’s case model to

bright red (rgb 255, 0, 0).

6Repeat the previous step for each button substitut-

ing the appropriate colours; green (rgb 0, 255, 0) and

blue (rgb 0, 0, 255). File > Save the movie as “mobile

phone” and then go to File > Create Projector. Add the

mobile phone movie to the projector and click the

Create... button.

STEP FIVE: Using 3D behaviours

Macromedia Director
Support Centre
www.macromedia.co
m/support/director/t
echnotes.html

On the MacFormat
cover CD:
■ Director 8.5
Shockwave Studio
demo
■ Amapi 3D 6 demo
■ 3DSpeedport OBJ
to W3D file convertor
(downloadable from
download.macrome-
dia.com/pub/direc-
tor/obj/mac/obj_con
verter.sit)

GOING
FURTHER
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